Warning: Illegal string offset 'html' in /home/nissansi/public_html/forums/cache/skin_cache/cacheid_1/skin_topic.php on line 907
Fan noise after thick radiator install - Hardtuned.net

Jump to content


Fan noise after thick radiator install 

1 reply to this topic

#1 stockblues15

  • Joined:06-April 13
  • Location:Australia NSW
  • Car:JDM S15 Spec-R

Posted 02 December 2017 - 01:17 PM

Not sure if anyone else has noticed much more fan noise after installing a 52mm alloy radiator. I never used to notice any fan noise with the stock radiator. I think possibly the viscous clutch is getting to much heat as it is now physically closer to the radiator code, making it operate harder earlier. This happens even on cool days after 20 mins or so driving.

Engine is basically stock with Nismo thermostat and alloy china radiator (52mm triple core). Engine temps are fine (probably cooler than they should be for daily driving) and system has been bled.

I just want to know if this is a normal thing with an alloy rad replacement that I haven't seen mentioned before.

#2 6330

  • Joined:18-February 05
  • Location:Australia WA
  • Car:S15

Posted 19 December 2017 - 12:17 PM

I would double check the clutch fan is mounted properly if you removed it when installing the new radiator.
The water temps would be running low because the combination of the oversized radiator and Nismo thermostat.
Personally I think the Nismo ones aren't needed.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Common Links

  • About Us
  • Privacy Policy
  • User Agreement
  • Help & Support Forums
  • Advertise
  •  

    By your continued use of this site, you agree to follow all Rules & Guidelines and abide by the User Agreement outlined in our Terms & Conditions.

    Hardtuned Network is hosted by Sanity Technology

    Design, Site Management & Hotness provided by Loz.

    Big thanks to all our members and volunteers for making this network what it is today!