Jump to content

stef_s14

Standard Member
  • Content count

    122
  • Joined

  • Last visited

Community Reputation

1 Neutral

About stef_s14

  • Rank
    Standard Member

General Info

  • Location
    Australia TAS
  • Car Type
    Nissan Silvia
  • Car Model
    S14
  1. SR20DET boosting problem

    Yes looks to be open a bit. They usually sit straight up when closed. All your issues definitely sound like a open wastegate flap
  2. missfire

    Does it miss on and off load? What's plugs and gap are you running?
  3. Camshaft options

    absolutely spot on!
  4. Camshaft options

    I switched from some kelford 264/272 staggered cam setup to some 256 poncams with a 3037s and it's a lot nicer and easier to drive, a lot more torque in the low range also. A heap of other sr owners I know run the bc cams but they do need dialling in to gain the most out of them.
  5. Cut some fuel hose or vacuum hose in half and run that around the edge of the hole in the battery tray, you can also drill small holes and cable tie it. Just get some conduit as well and wrap that around it
  6. Pressure plate could be stuffed causing your slave rod to travel too far and pop out. With the slave removed see how far you have to push the fork back to get the throw out to touch the plate.
  7. KTS vs CUSCO vs KAZAMA

    If it's a daily / street driven car get the hardrace rubber arms. I had some kts rear camber and toe arms and the bearings lasted 8 months. Any pillowball joint even with dust boot will wear quickly with everyday driving. I can't fault the hardrace items!
  8. I had a kinchrome 19.2v one for work that I used for 4 years. Never even needed a air rattle gun as it undid absolutely everything! I would have been undoing at least a hundred wheel nuts a day on the same battery. Downfall was that the batteries die fairly quickly and are super expensive to replace.
  9. The centre airbag/horn assembly is most likely not pushed in properly or not sitting square. Pull the centre bit back out and try push it on square
  10. Might be worth to either do a proper leak down test or just get a fitting to screw into the spark plug hole to pressurize cylinder, turn engine to close valves, put it in gear and see where it leaks. How does it start when cold? There are not too many options that would cause you to have low compression in all 4... As mentioned above already I would go to a w/shop that has a inspection camera to inspect pistons/bores without taking head off
  11. As mentioned above! You can buy a Chinese 600x300 that will work efficiently but a good quality smaller cooler would do the same job with Lower IAT and less pressure drop. Look into the pwr range if you are looking for a real good quality cooler. Tao from hyper gear had a few dyno results on different coolers and their respective IAT's and pressure drops so might be worth having a look!
  12. 100psi across all 4 is pretty low even if it is a low comp engine. Sounds like you possibly cracked some pistons. What's it sound ike running with the oil cap lifted slightly off?
  13. I ha the same issues on my s14 but in my case the inside springs on my double valve springs were broken. Did you re use the same valves? Did you clean them before fitting? I haven't seen it with sr's but we have a lot of problems with valves sticking on falcons due to carbon residue on the valve stems. Try turn it over by hand and see if the stems move freely...you have cancelled out most of the other possible causes that I could think of
  14. ^ ^ this! Undo a coil at a time to take the load off that cylinder and see which one quietens the noise down! Bit hard to hear on phone speaker but sounds like a bottom end rattle to me
  15. sr20 s13 and s14 cam shaft caps

    The cam caps are machined to the head and in a rule of thumb should not be swapped out as you could run into clearance issues!
×