Jump to content


Standard Member
  • Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral


  • Rank

General Info

  • Location
    Australia NSW
  • Gender
  • Car Type
  • Car Model
  1. Wow thank you pmod for such an in depth reply and getting all the specs and comparisons, as well as some helpful quick things to test! What you say definitely makes sense and yea might just be something to get used to And yea s15rocket, total feels for the delay with prius' before catching up haha
  2. Hey my '92 180SX SR20DET redtop seems to have abnormally slow acceleration below 2.5K revs. My previous 96 Civic would be way more responsive and even accelerate faster than my 180! (at that low rev range). One common example is waiting on a busy road wanting to turn right into a side street but oncoming traffic is super busy. When I see that small gap in traffic, and I want to quickly gun it into the side street, I'll floor it in first but it'll take ages for it to get really moving and have subsequently had a few beeps from people cos I was going too slow. This issue isn't just 1st gear either. As soon as I change to 2nd gear and put my foot down, there'll be this one second of lag as the car seems to catch up and then accelerates normal beyond about 2/2.5K RPM. Same thing for 3rd, 4th and 5th gear - always this wait for the car to respond and then it jumps forward. IDEAS?
  3. Thanks for that, it could just be the button is broken. Winding them down manualy and pressing it pops them up but not vice versa. Which contacts would I have to cross? I didn't really understand the wiring diagram
  4. And yes I've pressed that headlight button to the right of the steering wheel thousands of times (I feel) and nothing works..
  5. Interesting.. based on that I looked them up and found 180SX stalk: https://www.efisolutions.com.au/headlight-indicator-stalk-180sx Silvia stalk: https://www.efisolutions.com.au/headlight-indicator-stalk-s13 But then comparing to videos I took when dismantling it, I see that I have that extra cord going out of mine. However, I do remember when I was undoing stuff around the steering wheel that there was another plug that wasn't connected to anything.. maybe I'll take it apart again and try put the headlight stalk foam covered plug into that other one and see what happens
  6. Hey guys, first post after getting my first S13 and as a lot of others I've seen, my 180SX headlights don't go down. The motors appear to be working as when I wind them manually down and press the headlight button, they flip up straight away no problem. However, if they're wound down and I turn the headlight stalk, the lights will come on but headlights won't pop up. Have read through a bunch of posts previous to this and have tried most things Namely: Relays - heard them all click when applying power directly to them, switched the 3 on the right relay box in all arrangements and power is getting through Checked power out from male end of connector going from a engine to headlights themselves and got 12V readings. (Did this a couple of weeks ago but I'm pretty sure we checked this) Headlight stalk - removed and opened up fully, cleaned contacts (even though they weren't really dirty or scored at all) Headlamp timer - pulled out, opened up and checked inside. Didn't do any direct power tests to this as it seemed in brand new condition and there were so many outputs Checked all fuses Pressed the headlight button many times out of frustration Any more ideas? Would I go to look at all the wiring now? Cheers!