Jump to content

willy002

Standard Member
  • Content count

    193
  • Joined

  • Last visited

Community Reputation

0 Neutral

About willy002

  • Rank
    Willyz
  • Birthday 07/22/1987

Contact Methods

  • MSN
    se_xual_chocolate@hotmail.com

General Info

  • Location
    Australia NSW
  • Gender
    Male
  • Car Model
    BN SR20DET 180sx
  • Occupation
    A/C apprentice
  1. Make : NISSAN SILVIA Transmission : Manual Kilometres : 159000 Price : $15,000 Condition : Used hey guy up for sale is my blue 2000 nissan silvia s15 spec r greddy turbo 160,000kms mods: has greddy tdo6 20g turbo on a high mount custom manifold with greddy external gate tomei poncams walbro pump hdi frontmount excedy hd clutch vct about 10,000kms old hdi electronic boost controller silvers neomax coilovers boot carbon vinyl wrapped hks silent hi power exhaust custom one piece dump/front pipe high flow cat kenwood dvd player screen thinks thats it cars been hardly driven for the past 6 months just have no more time for it all you pretty much need is bigger injectors and a tune on this set up and you will get big power sitting on stock wheels atm (painted black) but have 19in dished wheels aswell only problem with the car is the right rear guards paint is a little off (wrong mix of paint, shown in pic) from a respray after guard flaring hardly notice it unless in bright sunlight may consider swaps plus cash my way or a yamaha R1 2009 and up more pics on carsales search SSE-AD-2519972 looking to get $15,000 for it so no low ballers and time wasters thanks, Wilson 0434209802 txt or call
  2. You still sell these clutches if so i need one fir my s15 possibly hd organic?
  3. CA Parts!

    Hey any s15 vct in stock?
  4. yep no.2 but as i said it runs better when o2 sensor is unplugged but it eats too much fuel so i wanna plug it back in.
  5. nah it warms up normally.. just idle/runs crap as i drive for longer..
  6. while on this subject... i just keep my o2 sensor unplugged coz when plugged in it idles rough and runs crap as it warms up longer bought a new sensor and still the same.. consumes more fuel but runs smoother for sum reason.. could my coolant temp senseor be stuffed?
  7. k so i gots the ratlle / tapping noise i assume its vct havnt heard this before as i only had redtop sr before it use to come on and off but now its permanent i assume its vct coz i used to hear switching noises before it wuld come off before but now the more i look amd listen to it im thinking different.. I put a metal rod where the vct is and dnt rally hear the noise from there.. I can hear it more on the exhaust side above the manifold. Could it be lifters / valves.. Is there anyway to check for sure?
  8. turbine wheel

    Crap thought itll be an easy job! maybe time for a 2871r but then i gota get a pfc.. if not jus gna get a 2nd hand one. got the manifold from gktech couple of months ago. jus put it on last week. and this happend
  9. ive stuffed up the turbine wheel on my s15 t28bb( welds from exhaust mani broke some fins).. now it doesnt boost right and has a whoooing sound when it comes on boost.. jus wondering if i can buy just the turbine wheel from anywhere.. shouldnt be too hard to change tht..? rather than getting another turbo
  10. s15 issue

    so wat i did is advanced the timing even more just a little bit this is way off the marks now maybe another 3-4 lines??.. but the car ran fine drove it it for an hour no probs exept today when i drove for an hour and ahalf it started struggling but not as bad as before.. could the crank angle sensor go out of its markings and cause the timing to be out that much..?? or previous owner pulled it out and jus slaped it back in.
  11. s15 issue

    so i checked my timing with my timing light and it was over the 20 mark probli more than 30deg or more. So i adjusted it to go 15deg then drove it nxt morning and problem was worse it struggled even when cold so i changed it back as close as i can where iit used to be and it went back to the normal problem after 15 mins. Could my cas be stuffed?
  12. s15 issue

    also had a mechanic plug in the scanning tool and all it said was system was ok.. If it was timing or ecu it wuldve showed a fault right?
  13. s15 issue

    car was stock apart from a pod and zorst.. till i put coil packs and pump and front mount but the problem was there before all that jus normal driving it still happens. at the start the idle was goin up and down till i adjusted the idle and it stopped. then this problem
  14. s15 issue

    just having an issue on my s15 here and im stuck. Wat it does is it works perfectly at the start when i its cold even when warmed up abit but when driven abit longer about 20 to 30mins after it struggles to make power.. Theres boost but no go struggling bad.. So i thot fuel pump yep change to walbro still nufin. Then mayybe fuel reg changed to second hand one still nufin. Then thot coil packs got supersparks .. still same thiing. So im thinking now afm .. But before i spend more money jus wanna see wat you guys think maybe the afm getting hot? Neway to check if its faulty?
  15. s15 issue

    just having an issue on my s15 here and im stuck. Wat it does is it works perfectly when first started even when warmed up abit but when driven abit longer about 20 to 30mins after it struggles to make power.. Theres boost but no go.. So i thot fuel pump yep change to walbro still nufin. Then mayybe fuel reg changed to second hand one still nufin. Then thot coil packs got supersparks .. still same thiing. So im thinking now afm .. But before i spend more money jus wanna see wat you guys think maybe the afm getting hot? Neway to check if its faulty?
×