Jump to content

rocket.200

Standard Member
  • Content count

    43
  • Joined

  • Last visited

Community Reputation

0 Neutral

About rocket.200

  • Rank
    Newbie
  • Birthday 02/15/1990

General Info

  • Location
    Australia NSW
  • Gender
    Male
  • Car Type
    Nissan Silvia
  • Car Model
    AUS spec 200sx s15
  1. sputtering and misfiring on a hot day

    Hey guys I know its been long time since replied haven't had had the car going for a while. I have changed plugs followed some peoples advice and bought bcpr7es as the are a colder plug. Regapped to 8 took it for s test drive and started to miss fire Regapped to 7 and still the same Regapped to 6.5 and still misses but now has rough idle Any suggestions with maybe a different plug heat rating or gap????
  2. sputtering and misfiring on a hot day

    This problem just wont go away!!!! Still have the same problem after gapping spark plugs to .7 anyone else know what could be causing this issue??
  3. sputtering and misfiring on a hot day

    Thanks again everyone for there input I purchased a gauge for the plugs they were already at .8 so regapped to 7 im not sure how much of a difference it has made I have to wait for another warm day.
  4. sputtering and misfiring on a hot day

    Probably a stupid question but to bring the gap down do you just press them on something hard?
  5. sputtering and misfiring on a hot day

    Thank you so much for all your helpful tips and info il give it ago tonight il get some new copper ones. What is the best gap?
  6. sputtering and misfiring on a hot day

    Yeah its something that I will check cause its happens underload anywhere around 4 to 4500 rpm I havnt looked at the boost gauge to see what psi im at when its doing it. It might sound like a stupid question but how do you check the gap and re gap im the complete opposite trade to a mechanic lol
  7. sputtering and misfiring on a hot day

    They are ngk platinum not sure on the gap my mechanic through them in on the last service a couple of weeks ago
  8. sputtering and misfiring on a hot day

    Walbro I cant honestly remember the model. Il have to try and ring them tomorrow I just cant work out why it only happens on hot days.
  9. sputtering and misfiring on a hot day

    Yauvz tuned and I think mark installed the nistune board
  10. sputtering and misfiring on a hot day

    Im running 17 low and 19 high it was all set up by unigroup 18months ago
  11. If blitz ic piping still for sale il take it
  12. Have you got pic of steering wheel
  13. sputtering and misfiring on a hot day

    Hey guys I know its been a while still havent resolved the issue I have bought new coil packs and replace spark plugs. After changing coils it made a big difference but the hesitation still occurs just not as bad. Any help would be very appreciative.
  14. sputtering and misfiring on a hot day

    Havent put spark plugs in for a about 6months is that too long?? Thanks for your reply.
  15. Hey people, Just wandering if anyone can help me. I was driving my car today and it was pretty hot so I wasnt trying to thrash it. I was in 3rd gear around 3000 rpm when mmys15 started to loose power and start sputtering. Car:2001 s15 aus spec Mods: exhaust Intercooler Bov Intake pipe with pod Fuel pump Nistune Yellow jacket coils Any direction where to look would be a great help if anyone has experienced anything similar. Also the fuel pump after I had finished driving was whinning rather loud. Thanks everyone
×