Jump to content

Search the Community

Showing results for tags 'Alpine'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 1 result

  1. Hey everyone! not to sure on where to post this, so i figured here was the best place In my S14 i have new Alpine type S speakers, fronts, tweeters and back speakers. i have a headunit with 50W x 4 and a 330CCA battery in my engine bay Im looking at getting a 4 channel amp to boost the power a little. The speakers are 80 watt RMS and 240 watt peak power What sort of wattage per channel should i be looking at... 80 watt per channel? more or less? Im not really sure when it comes to audio and power. i found a blaupunkt amp that has 70w x 4 @ 4ohm which i thought looked good, but it may not be enough power. it was $220 delivered which is around my range at the moment Cheers for any help, suggestions or experence stories (: Glen
×