Jump to content

Search the Community

Showing results for tags 'Fuel Pump'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 12 results

  1. So basically my problem is my fuel pump keeps cutting in and out randomly, iv checked my fuse which is all good and iv also swapped my relays so i know the relay isn't the problem either i can get the car running by bypassing relay number 2 and 5 and my fuel pump stays on but not 2 and 3 which everybody on google says to do and works for them on my relay number 3 and 5 have a break indicated on the relay which Leeds me to the question of does number 3 need a constant power to transfer power to number 5 when the relay connects that circuit? Iv checked voltage from the pin sockets on my relay socket 1 - constant 12v with ignition on (ecu power?) 2 - constant 12v with ignition on 3 - nothing with/without ignition on 4 - nothing with/without ignition on (power wire to fuel pump) all sockets have an earth apart from 3
  2. r32 GTR intercooler $300 r32 GTR stock twin turbos $400 r32 GTR twin BOV $70 r34 GTR stock twin turbos (minus wastegate actuators and damaged compressor wheels on both) $320 s14 standard drivers seat $40 s14 5 stud rear hubs $200 s14 ABS brake master cylinder $50 s14 Rear camber, toe and track arms $80 for the lot or $30 for each set. VDO adjustable fuel sender and gauge Walbro GSS 342 intank pump approx 1000km old Pick up location Parkinson QLD For more info call 0431284873 or message on here. Cheers Shannon
  3. Finished putting the car together tonight ready for tomorrows tune, went to start it but only cranks and doesn't turn over! Couldn't hear fuel pump prime on ignition so checked the fuse in the drivers side foot panel and is good. Then tried seeing if there was any power at the fuel pump plug to rule out dead fuel pump, couldn't get plug off seems to be fused on so spliced into wires with a multimeter, no power through wire.. The only things left i can think of is the relay (located?) or ecu. How would i test these as there's no power getting down to actual pump. Is there anything else i should check? Thanks in advance
  4. Hey enthusiasts. I have question for you regarding surge tank setups. I'm wanting to run e85 system. does the in tank pump that feeds the surge tank need to be e85 compatible? Or can I run the Walbro 255Lph pump I already have and just get a hight output e85 compatible external pump that actually runs the fuel to the engine? And what size external pump should I be using when im looking at making 360rwkw with injector dynamics id2000? Ide appreciate any information on this as all I have at the moment is the injectors and 255Lph Walbro which I'm happy to sell if needed.
  5. S15 or R34 fuel pump wires

    As the topic describes, I am after the wires that go onto the fuel pump for an S15/R34 (same wires/plug).
  6. 180sx upgraded fuel system e85

    hey guys due to chasing more power im now selling my stealth e85 fuel system which consists of: 4 x ID2000's with rail powertune billet twin intank bracket twin aeromotive pumps (340lph each) inline filter speedflow fittings and all the braided lines from front to back -10 $2750 the lot Contact Troy on 0403 131 921
  7. ok so i'm at the point where i'm in need of some wiring fingerbanging guy/chick to come and say have you checked this and its 1 little wire or something i've missed and then she starts. So i done the whole SR20de to SR20DET conversion and the 2 wires behind ze headlight bridged (thanks to wizard and his mad soldering skills) now this is all that should have needed to be done to go bang bang but no... issue 1. No power to ecu pin 36 Issue 2. No Fuel pump priming issue 3. Passenger window wont work now... (No its not the amp) issue 4. Wiper is turned on After repairing a few wires from a doner loom (Another thanks to wizard) she seems to be getting spark to all coils and all injectors are pulsing and she wants to start buuuut NO FUEL! the EGI relay seems to be clicking off and on like it should and ive checked every fuse 3 times now after every attempt to fix and my fingers are killing ive tried grounding the thick blue/red stripe wire from fuel pump and that still dont work i removed old pump and replaced with a walbro new cradle and wiring just coz and still no priming. i tried bridging the power wire to fuel pump wire in brown plug but think i hit the wrong wire as thats when the wipers turned on - obviously i disconnected it but its still acting as if its on when its off. Any thoughts of saving me from going insane is deminishing at an alarming rate and would happily accept anyones thoughts or ideas on what possible things i can check PS. wipers and window can go to hell for the moment its winter anyways
  8. Brand new Walbro E85 500hp Intank fuel pump kit. This was bought for my BNR34 but never got used. $200 Having trouble uploading photos on phone, will upload once I get to my computer. Sheldon Gold Coast
  9. What up fellas? Just wondering what the best fuel pump to drop in my silvia would be? looking for something to replace the stock one (its kinda on its last legs), that will do the same if not better? thinking a walboro 255, thatd give enough room for modding if i wanted to?
  10. Not sure if this is the right place to post.. My car is a 1996 180sx type x and has been off the road for about a year, but during that year i started it every so often, drove it abit just up and down my street, everything seemed fine. Now that i am trying to get it back onto the road, i changed sparks, oil, oil + fuel filter and gave it new fuel. So i drove my car to the mech to get a rwc, few hrs later get a call that he cant start the car, he said the fuel pump shit itself, he said he can order a replacement which i said yes bcoz i cbf fixing it i just wanted him to finish the rwc. He replaced the pump did the rwc told me needed few things to fix. atm i am trying to fix those things one of which i needed to go to a panel beater for a structual report which i did, drove there fine, after it was all done time to leave, when i tried to start it, it wouldnt work, fuel pump didnt prime, kept trying and trying and eventually got it started after that drove it to a mates place to work on it. When it came time to leave the fuel pump didnt prime again i couldnt get it started at all anymore so its stuck at my friends place. After checking all wiring, fuses and relays everything seems fine. I noticed that there is relays behind the fuel box on the drivers side kick panel, but i couldnt get them out to test, there is 4 of them, what are these for? With the fuel pump wiring i used a multimeter and im getting power from the yellow/green stripe and soild yellow wire, but im not gettin power from the white/purple stripe wire. So i hooked a power source straight from batt to pump onto the white/purple wire and pumps fine, i made a switch onto the wire to turn on and off the fuel pump as a temp fix so i can drive it home, tried starting the car with the fuel pump on, but still nothing, it cranks over but doesnt doesnt start. Took a coilpack out, put a spark plug in and grounded it (not sure if we grounded it properly), tried starting it, couldnt see a spark. Idk what to do next. im stuck Any help would be appreciated as i just want my car to be on the road again... Sorry if its too long to read, just thought details would be nessecary. Im still learning cars so im a bit noob lol.. Thanks
  11. HI all! Sorry to be a newb to the import scene but it seems I have a major problem with my sil. Heres the specs in case you need em... 1991 Silvia K SR20DET I've recently had the engine rebuilt by my local mechanic, but noticed sluggish acceleration and a bad fuel smell, After a chat with a mate I decided to let the boys at XSpeed performance centre have a look at the problem, long story short, my mechanic is an idiot and hadnt thought to check if the fuel pump had failed. After a bit of a closer look XSpeed reckons the failed pump was the cause of the first engine failure. They want to charge me $600+ to change the fuel pump, to a new still stock pump. After talking to another mate, he has hooked me up with a Walbro gss342 255LPH. Now I'm not sure but I think fitting a larger aftermarket fuel pump for cheaper would be a good idea if I decided to do power mods in the future! Im asking if anyone on these forums has any experience with these fuel pumps in particular and could write me a how to guide on installation and tell me some things to watch for. I really appreciate you useing your time to help me, Thankyou, Justin.
  12. Looking for a new pump for my s15. Going for e85 with 1000cc and the Walbro 255 I have at the moment wont cut it. Looking for opinions/options that anyone has? I'm leaning towards the new Walbro 400LPH however I am finding little information and no hype (strange considering it seems great for those in my situation - going e85 but not wanting to go dual pumps etc). The options are: New Walbro 400LPH Deatschwerks DW300 Aeromotive Stealth 340LPH
×