Jump to content

Search the Community

Showing results for tags 'brake'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 8 results

  1. I have just become aware that the S14 (not sure if all or some) had OEM brake ducts attached to the caster rods. It would seem like a simple retro-fit to an S15 to get some additional cooling. However I am surprised that this is not mentioned much, and after-market rods don't have anything like this. Which brings me to the million dollar question, are these effective or just a waste of time?
  2. S13 ABS Pump

    Looking for a good working ABS pump, Nippon 47600-39F00, for a S13/180.
  3. Hi All, Brand new in box, Project Mu handbrake shoes for sale. Part number is IS200A. Bought these to fit to my 180sx with rear R33 GTS-t brake setup, however never came around to fitting them up and using them. No longer needing them. According to Nengun, they are compatible for... Nissan - Skyline - R33 GTS-t S2 - ECR33 Nissan - Skyline - R33 GTS-t S1 - ECR33 Nissan - Skyline - R32 GTR - BNR32 Nissan - Skyline - R33 GTR - BCNR33 Nissan - Skyline - R34 GTR - BNR34 Nissan - Skyline - R32 GTS-t - HCR32 Nissan - Cefiro - A31 Although, please make sure you double check beforehand. I'm after $200 delivered to anywhere in Aus via Express Post! Preferred contact via sms on zero four two one 1 2 1 eight one eight. *Pics to come in this thread, or can be seen attached in the shitty bootcruising classifieds format* Cheers, Andy
  4. So i took the my s14a for a good drive yesterday (first real test since building it) through the hills and started to get some pretty bad brake fade. Before heading out, i did have some brake issue with the brake pedal needing to be pressed all the way down before engaging the brakes. I had bled the brakes twice before but still felt like it had air in the system? I've checked for leaks and all is good. Rotors also look good, look recently machined. Also when pumping the brakes, you can hear air being pumped like from a bicycle pump, is this a normal sound? Since yesterday the brakes squeal like a b*tch when pulling up, even just daily slow driving once heated up. Trying to figure out how to fix this problem?? Im running: ABS removed BMC44 master cylinder S14 (4 pot) front brakes (drilled rotors) R32 GTR (2 pot) rear brakes (solid rotors) Unknown new pads all round (came with car) Penrite Super Dot 4 brake fluid Also I have been bleeding the brakes from the calipers only thus far, furthest one to closest as usual. But a friend has told me to try bleeding from the master cylinder first so ill give that a try when i get a chance. I've never had to do this way before but is this the right method, bmc first, then calipers as usual?
  5. Hey all my S15 has 95000 kays on it and i have some marks on both front rotors. I have Lucas TWR pads and have done one track day Does anyone know what this means
  6. Brake bias questions.

    Hello NS. Had my S15 almost 2 years now and use it as a daily. Replaced all 4 brake pads when i first got the car. The rears are pretty much finished now, but the fronts still have loads of meat left on them. A mate pointed out that my car must have a pretty heavy rear brake bias. Aside from a couple of times before when ive been surprised at how easy it was to trigger the abs off (usually in the wet), ive had no issues with my brakes and they feel fine and strong for street use. So my questions are would having a rear brake bias have a big effect of braking and handling for street driving? Is it worth changing it? And how would i go about changing it? Cheers!
  7. hey guys i'm kinda new on this site and have some questions. I have a stock 180sx with stock brake and everything and just started drifting but my e brake wont lock up i already changed the pads and adjusted the brake line but it still wont lock. I'm really getting tired of it and want to install a hydraulic e brake on my ride or just fix this problem. Everybody i know is telling me i NEED to change my stock brakes and install skyline or silvia brakes. Is this really so?? pls tell me
  8. Hi guys On my 91 S13 I having a strange problem with my brake lights all is well when the headlights are off but when. But when I have the headlights on the tail lights will work no problem while the brake is not being used as soon as I press on the brake the passenger side tail lights and brake light go off. So far I have checked to see if one of the two bulbs were causing the problem but even when I have one in only I get the same result and I have had a glance over the fuses and all look not blown but I might not have looked at all the right ones. I am wondering if anyone has suffered the same problem and what they did to fix it Any help would be appreciated Thanks
×