Jump to content

Search the Community

Showing results for tags 'coolant'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 4 results

  1. Hi guys Noticed at time attack yesterday that my car was leaking coolant, jacked her up and had a look underneath and could see coolant leaking from a bolt/line on the turbo Anyone else had this happen and how much of a pain in the ass is it going to be to fix ? Also took a video and posted it on youtube showing the drip
  2. Brief description of my problem: Upon cold starting my car, it will take roughly 10-15 minutes for the factory temp gauge to even begin to move. Im sure this could be very normal on most cars however...my real issue begins when i actually start driving, once the car is under load or i am driving up a steep hill, the temperature will shoot up to 76 degrees, (pretty standard i think) Although the second i start driving down a hill the temperature reading will drop dramatically, usually to just below 50 degrees, that is, so the factory temp needle has returned back to the bottom. Variabilities/changes: Facts and things i have noticed or changed in an attempt to fix this, the motor is an sr20de running a stock radiator and a new thermostat. A clutch fan in good working order (swapped the old one out). I also have, a device to read the figures the ecu is picking up from the temp sensor. And a water temp gauge (defi) fitted in the upper radiator hose. This means i have two separate readings giving me roughly the same information (usually 3-2 degrees either way). Around the time this issue started i lost use of my aircon, it now just pumps out hot air. Coolant was flushed with new coolant put in, changed nothing. This problem has been going on for about 6 months and so far its not proved to be any sort of a serious issue however its just really confusing, id be really interested to know if anyone has had the same issue! If ive left someone out or more info is needed just abuse me. Thanks for any help!
  3. Hey guys, I have been doing a bit of research but still can't decide on what I am going to change/upgrade cooling wise. I have an N/A SR20DE S13 and have had some overheating problems which led to the engine dying. The engine is currently being fixed but I just want to make sure that it doesn't happen again. I was thinking of getting a bigger aluminium radiator and also and oil cooler kit but I'm not sure is that would be the right option as it's only and N/A engine. I'm just looking for some advice from people who have done any cooling mods to an SR20DE and also the cheapest yet most effective way to do so. Please feel free to comment as I want to gather all the information I can Thanks, Curtis.
  4. Hi guys, Need some local Adelaide peeps help. See Pic below. S15 JDM. Got a predator enginebay mount i/c and radiator kit...(when I bought the car came with it) See Pic below. The radiator recently had a leak on one the top tank right on the fold so I had that welded up which is all fine. However, a few weeks later I'm not having mystery coolant loss...I'm having to fill up the reservoir every 2-3rd day as it's sucking down all the coolant... I'd like to think I'm pretty handy with my mechanical abilities, I've checked the following.. Pressure Tested...fine Radiator Cap ok (new Nismo 1.3bar cap anyway) Checked both hoses and clamps...all seem fine No leak from waterpump checked oil cap for watery (Head Gasket) symptoms..none..besides, car runs and idles fine hot and cold.. compression fine no green coolant etc on spark plugs no coolant dripping on the floorpan...or groud thermostat opens and closes fine (tested by me) Can smell the coolant while driving a bit...engine temps stay perfectly in the middle. The only thing I can think off is when the repairs grinded back and welded maybe there is a leak there someone but certainly not visible (and also pressure tested fine? wtf?) Could there be air in the system...was thinking of emptying all coolant and refilling slowly whiling burping it myself...but otherwise, I'm at a loss. My second question is this. Heard that these kits arn't considered that great anyway - I'd be happy to get a new radiator and be done with it, but the problem is because of the customisation I can't exactly get one off the shelf...unless I buy a reccomended radiator and get some welding done to mount up the thermo fan and the brackets for it to bolt to the i/c? In a pinch, I would even consider getting a kit like a blitz I/C and getting a alloy s15 replacement stock radiator? Thirdly..I need a decent tuner/mechanic to goto. All the work since I've had the car has been by me which is fine, I had it dyno'd once by Southern Hi-Tech but to be honest I wasn't impressed with their service...or ability to do many custom mods/etc I'm looking at Garage 7 to do the following: Sort out my coolant issue Install Nisstune Fabricate Better Pipework for Hot/Cold pipe test and doublecheck thermo setup Dyno Tune etc... I'm sure a lot of you guys have had good experiences with G7 and Declan's tuning... The rest I'm happy to do but I def need to build a rapport with a good solid workshop and tuner that I'm going to trust my car with in future for my Build plans. any advice/help is appreciated..SUCKS working in the City and being away from some great tuners that I can't just easily leave my car with and trust to do a good job..
×