Jump to content

Search the Community

Showing results for tags 'low power'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 1 result

  1. Hey all. Looking for opinions on those who would know what is wrong - if you look at the dyno, it is just not good. Mostly validate if I need bigger size cams, etc. S15 Jap Spec-r. Running GTX2867r with 86 rear housing. (brand new Gen2) Stock cams. 850cc Injectors (JECs side feeds, flow tested), splitfire coils (blue ones). Blirtz Spec-r boost controller. Custom hard intake pipe (3inch?) 455L Walbro Fuel Pump. Z32. BKE7 something spark plugs (new and the correct ones). Kakimoto Regu 06&R with resonator removed. High flow cat, tomei 3" dump. FMIC (generic). As the dyno results show - no power. People like to blame the housing, others the tuner. The tuner is good, those who he is all agree. The figure is way down regardless of the housing size. I don't believe the housing is the issue either. Just a LITTLE more lag. The timing was not advanced further due to detonation. FYI comp test is fine (135 to 145 across all 4 from mem). Leak test done - no boost leaks. The car had the T28 before and would move even at 6th gear at 100km/h, my old S15 had a 2871r 0.64 and moved still without a tune more at under 5kRPM. Again, No boost leaks, injectors have been tested. With no cat and exhaust it made 192kw. So that eliminates the exhaust. I want my bottom end back and my 260kw I should have. Tuner is saying E85 and cams are needed as some SR20s just don't make power. I am hoping not to rely on E85 to make her move again. With all the above info, WHAT THE HECK IS WRONG?!?!? Thanks all.
×