Jump to content
Sign in to follow this  
Voyz180

car running shit after new tank of fuel, is there anything i can do.

Recommended Posts

hey

 

so my car was running fine for a drive before i went to get petrol and on the way there, but after i filled up a whole tank of bp ultimate the car started to run real funny. the exhause note has changed and sounds like its purring more so like real slight popping almost sounds good but not. it also has f**k all power.

i even thought it could be running on 3 cylinders but i checked all my spark plugs when i got home and they all look sweet. will try coilpacks tommorow.

now i cant be sure its the fuel because ive never had a bad fuel caused problem before but its looking that way.

is there anything i can do like go complain and get me money back becuase i really cant be f**ked draining the tank wasting 70$ worth of fuel.

f**k BP this has given me the shits.

would chuckin in some octane booster help? i thought it was weird they had 80% of there pumps closed.

is there anything else it could be?

180sx sr20det with powerfc 220kw

Edited by Voyz180

Share this post


Link to post
Share on other sites

That's weird they had 80% of their pumps closed, you should definitely talk to them about it and if it's a bad batch of fuel there would be more people having issues as well

I knew someone years ago who worked in a servo and if their fuel was deemed as contaminated or faulty they had to cover the costs of getting fuel tank drained etc

Share this post


Link to post
Share on other sites

went to the servo and the guy said if i can prove the fuel was the cause then they could do something

Share this post


Link to post
Share on other sites

Just from what you've said it sorta sounds like it's going into limp mode, doesnt necessarily mean it's bad fuel, maybe shit got stirred up in the tank and blocked the fuel filter or some other coincendence but check back with the station tomorrow and see if they've had anymore complaints.

Share this post


Link to post
Share on other sites

A mates car did this too. He seemed to have gotten the last of the fuel stored in the servos tank. Pulled his fuel pump out and we had rocks and sand covering the pump intake sock. It's easy enough to pull the cradle and have a look man

Share this post


Link to post
Share on other sites

Da f**k is limp mode?

Like a safety mode if something f**ks out it does shit like cut cylinders and won't rev past 3000 rpm to limit damage to the engine and so you can "limp" home. Most cars have it

Share this post


Link to post
Share on other sites

thanks guys but it wasnt the fuel, one of my connectors on a coilpack is f**kd which came loose and caused the shit running issues.

all good now.

cheers

Share this post


Link to post
Share on other sites

Da f**k is limp mode?

 

It's a feature all your tunes should have :P

Share this post


Link to post
Share on other sites

Da f**k is limp mode?

 

It's a feature all your tunes should have :P

 

Chew on some cock please :)

Share this post


Link to post
Share on other sites

Da f**k is limp mode?

 

It's a feature all your tunes should have :P

 

Chew on some cock please :)

Do you mean to say you'd like him to get some Red Rooster?

Share this post


Link to post
Share on other sites

Da f**k is limp mode?

 

It's a feature all your tunes should have :P

 

Chew on some cock please :)

Do you mean to say you'd like him to get some Red Rooster?

 

no, i would like him to chew on my penis :) He knows he wants to, there's no denying it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×