Jump to content
Sign in to follow this  
Myles_SR20

S14 sr20det t28 laggy

Recommended Posts

Hey guys, recently took my car to the tuner after my rebuild. The cars a s14 sr20det 9.0 comp with a t28 on 14psi. He started to tune it but realised it wasnt coming on full boost until 4000rpm and it should be there by 3250-3500rpm. Any ideas what would make it lag this much? He mentioned it may be the vtc gear stuck or the cat being blocked. Seems really odd

Share this post


Link to post
Share on other sites

Vct stuck ?

 

Cas properly timed or aligned?

 

Blocked cat or restrictive exhaust yes possible.

 

Could also be split cooler pipe work.

Anything really.

Including the tune.

Share this post


Link to post
Share on other sites

Are you sure the wastegate isn't stuck open to some degree? That will kill response.

Share this post


Link to post
Share on other sites

Pull the exhaust off before the cat, that would rule one problem out

Share this post


Link to post
Share on other sites

Vct stuck ?

 

Cas properly timed or aligned?

 

Blocked cat or restrictive exhaust yes possible.

 

Could also be split cooler pipe work.

Anything really.

Including the tune.

 

Yeah Ive heard of a vct gear wearing out and ticking but never stuck in the retarded position...

 

Ive aligned the cas correctly, checked multiple times before fitting the rocker cover.

 

I will have to try putting the back pressure gauge on or removing the exhaust. But was told it wouldnt even make 14psi boost if it was blocked?

 

Just made a boost leak tester, will have to try it out this arvo.

 

There was a crack in the turbine housing where the wastegate flapper sealed but didnt think it would make that much of a difference??

Edited by Myles_SR20

Share this post


Link to post
Share on other sites

Can confirm wastegate leak will lead to a very bad time. Fixed my t28bb's kowabunga actuator preload by a couple mm and went from 16psi at 4500rpm to 16psi at 3500rpm plus way better transient response. Prior to finding that I checked for boost leaks, dead vtc, collapsed cat, knock sensor etc. If that crack has enlarged near your wastegate then there's a chance it could be replicating the same effect.

Edited by wrmdma

Share this post


Link to post
Share on other sites

Yeah exhaust leak and actuator problems will cause issues. And same with the crack if its big enuf.

 

I have a fucked VCT and still in by 4000 with gtx2876 and 260/12 cams. Wouldn't think it's the issue.

Vct won't retard anything. Just make down low a bit sluggish if worn out. And rattle like mofo.

 

Also check for bolt tightness on turbo, manifold, dump pipe etc etc.

Share this post


Link to post
Share on other sites

Yeah I have a manual boost controller.

 

The crack is only about 5mm long, so not very big.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×