Jump to content
Sign in to follow this  
KE70Mike

Hicas 34 GT-R

Recommended Posts

Hey guys ever since i have bought my R34 GT-R V-Spec my Hicas light has been on in the instrument cluster i have had a suss under neath un pluged all connectors cleaned them to make shure there isnt any corrosion

but nothing, light is still on any ideas where to start?

Share this post


Link to post
Share on other sites

Got an aftermarket steering wheel? Steering sensor could be misalinged.

 

Does the car feel unstable or anything when you turn at 60+k's?

Share this post


Link to post
Share on other sites

Got an aftermarket steering wheel? Steering sensor could be misalinged.

 

Does the car feel unstable or anything when you turn at 60+k's?

 

hey mate na stock steering wheel every thing feels fine besides the hicas light on the dash :S, i havnt felt it with hicas so dont realy know the difference unfortunatly.

Share this post


Link to post
Share on other sites

Are you using a genuine nissan key?

 

I had a key cut for my R34 and whenever I used it - it lit up the hicas light. Suss.

Share this post


Link to post
Share on other sites

HICAS light might double as low power steering level, well that was the case with my Ceffy. Did you check your reservoir?

Share this post


Link to post
Share on other sites

HICAS light might double as low power steering level, well that was the case with my Ceffy. Did you check your reservoir?

 

That's a good point. Being that it's a HICAS car it will have a power steering fluid level sensor in the reservoir. Non HICAS cars do not. Check the fluid level.

Share this post


Link to post
Share on other sites

Low power steering fluid, my old R32 and the S13 do it

Share this post


Link to post
Share on other sites

i kinda have the same problem but mine only comes on when you are under full load in 3rd for some reason and then it seems like all the power then goes to one wheel ? any ideas?

Share this post


Link to post
Share on other sites

i kinda have the same problem but mine only comes on when you are under full load in 3rd for some reason and then it seems like all the power then goes to one wheel ? any ideas?

 

34 GTR?

They have yaw control, which can change which wheels get the power to bring the car out of a slide. I have no idea how the sensors for this work. Try putting your screen thingo onto the G sensor page and see if it does anything weird. Possibly something wrong with the sensors?

Share this post


Link to post
Share on other sites

I have topped up my resivour and the light was still there, so kept asking around and found out that if the battery has gone completely flat at some point, this can bring the light up, apparently

dose not affect the way the hicas works but but for sum reason triggers the error code, i have plugged in a diagnosis scan tool and no fault codes came up so my guess is

that this is the reason the light is up on the dash cluster, and unfortunately has to go back to nissan to clear the code.

i will just put up with it now that i know nothing is wrong :).

Share this post


Link to post
Share on other sites

Take out the light :) lol mines been taken out. I don't even think my HICAS works hahaha! Mines electric not fluid driven.

Share this post


Link to post
Share on other sites

Take out the light :) lol mines been taken out. I don't even think my HICAS works hahaha! Mines electric not fluid driven.

 

no light no problem haha excellent.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×