Jump to content
Sign in to follow this  
ta2272

Clutch always going out of adjustment

Recommended Posts

Hey guys my clutch always seems to go out of adjustment and require bleeding or adjustment.

 

I have replaced both th slave and master cylinder"s and even put a longer rod between the slave and clutch fork.

 

The last owner had said I has a hd exedy clutch.

 

If anyone could help to why this may be that case?

Share this post


Link to post
Share on other sites

I thought I may need a nismo slave cylinda or a better pivot joint for the clutch fork due to the heavier clutch. Any thoughts?

Share this post


Link to post
Share on other sites

I removed it differently to how this guy did it, he removed the damper an then bent the line. I just removed the damper bit an blocked it off at the T junction it comes out of.

Share this post


Link to post
Share on other sites

Same thing happened to me when I replaced the stock clutch with a heavy duty. I removed the damper by bending the solid line. The clutch works perfectly now

Share this post


Link to post
Share on other sites

Spacenoodel did you remove it in a similiar fashion to the link the other guy posted, by bending it back around

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×