Jump to content
Sign in to follow this  
zenkii

Clutch issues

Recommended Posts

Hi guys,

 

Having issues with my clutch. Friction point is about 2cm off the floor. It also won't go into first or reverse.

 

Bled the system a few times and swapped over the slave.

 

What's my next option? Problem with the master?

 

cheers in advance

Share this post


Link to post
Share on other sites

yes most likely hydraulic related.

 

have you changed anything or has it only recently started doing it?

Share this post


Link to post
Share on other sites

Exedy HD was put in a couple of months ago. Has been fine until recently though. Was drivable last week with real low friction point but has been progressively getting worse and now won't engage at all. Pedal still has feeling, still goes in and comes back out on it's own.

 

Couldn't find any visible leaks from the master under the dash.

 

Also removed the damper inbetween the master and the slave but have bled the system a few times since.

Share this post


Link to post
Share on other sites

Is there an adjustable metal rod behind the clutch pedal that you can screw in and out?? try screwing it out to lengthen it. Had this problem in my 32 and that solved it.

Share this post


Link to post
Share on other sites

^thanks man.

 

Adjusted the master push rod, brought it out a bit and seems fine now.

Is this a band aid fix? Just wondering what's caused this?

Share this post


Link to post
Share on other sites

Had the same problem with my kia just adjusted the cable to make it tighter

Share this post


Link to post
Share on other sites

Its not a band aid fix. sometimes after a new clutch that adjustment needs to be made so now its disengaging the clutch properly when pushed in

Share this post


Link to post
Share on other sites

If your hydraulics (master and operating cylinders) are good and as you've put in a heavy duty clutch may there be the horrible possibility of the clutch withdrawal lever bending ?

 

I know there are heavy duty ones of these available which would lead me to think they may be a desireable upgrade if a heavy duty clutch is installed.

 

Also did you install a new master & operatng cylinders , use kits or just replace with second handys ?

Share this post


Link to post
Share on other sites

Did you change over the clutch pivot ball when you put in the HD clutch?

 

The stock ones are very weak and possibly it has broken in the bell housing of the gearbox.

 

If it has broken, get a Nismo one for ~$50. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×