Jump to content
Sign in to follow this  
DRE20

The Maroon Menace. 455kw monsta!

Recommended Posts

Ok so i've been asked by a few people to do a build thread so here it is. Happy reading :)

 

 

 

I remember seeing a green s14 series 2 cruisin around in my town waaay back in 2000, and ever since then i've always said once i get my shit together i'm going to get one. Well, my shit is together, and here is my beloved silvia's story.

 

For the record, this is my first turbo car so since buying it i've learnt alot. Didnt really have much to do with cars before this one, ive had a few but never really mucked around with them like i have with this one.

 

So back in 2010 around May whilst searchng on carsales for an s14, this little shiraz coloured rocketship jumped out at me... So i called up the owner and told him i want it, so i paid and he put it on a truck for me and about 2 weeks later my dad and I flew to townsville to drive it home (i didn't have a licence at the time so dad drove) this is it after i first got it registered with my plates slapped on it about 2 or 3 weeks after having it at home.

 

33391_1402047736835_257492_n.jpg33391_1402047776836_1996597_n.jpg33391_1402047856838_3625694_n.jpg34226_1402058817112_1481754_n.jpg34226_1402058857113_713495_n.jpg37358_1402047016817_1401573302_31146737_3578848_n.jpg37421_1402058217097_4888899_n.jpg37421_1402058297099_8137301_n.jpg303065_1402047816837_4937848_n.jpg

The car ran very well, we were quite impressed with it on the trip home, drove it for 1000k's flawlessly. The old man was a bit scared of the highboost setting lol.

The dyno sheet provided with the car said it had around 227kw atw, on somewhere around 20psi,

 

Specs of car:

 

Engine:

 

Stock unopened s15 VCT sr20det

 

Other Goodies:

 

garrett 2876r .64 A/R and 4inch front housing

stock injectors 370cc

Malpassi fuel reg

Hybrid front Mount Intercooler

3inch zaust from turbo back

4inch pod filter on custom alloy air pipe

Microtech LT8 piggyback ecu

Relocated Bosch coilpacks

Bosch 984 fuel pump

Stock Nissan Intank pump

Alloy surge tank

Oil catch can

Custom alloy airbox

Turbosmart Eboost

Turbosmart v port Bov

 

 

Didn't have a licence for the first 3 months of owning this car so it pretty much just sat around and every now and then me and mates would take it out for a drive, on this one particular night, maybe 4 weeks after having it home, me and a mate went out for a cruise, and i said lets go out of town so i can have a drive, i hadnt driven it yet not even once. So anyways, i get into the drivers seat, get the seating position right, adjust the steering wheel, push the clutch in and put it into first gear, slowly let the clutch out and take off then decide i wanna rip skids so i clutch kick it, then snap 2nd, them BAM! blew 2nd gear lol.

So thats when i joined this very website and started looking for answers and options on what i can do to make it not happen again...

Then i found the Z32 gearbox thread nigel created, and after about a week a user from here got onto me, he'd just stripped out his whole z32 conversion out of his s14 so i snapped that up, put it in and it was a bit of a f**k to be honest at first, it was very noisy, rattly, the gearbox was tappin the floor, the shifter hole needed to be cut out for it to fit properly, had no speedo, the gearstick rattled its ass out, oh man it was a f**king mess.

So i started researching, found a little company called Alpha Omega down in sydney who'd basically JUST started doing the conversions, well, they weren't officially released yet but after a few emails i managed to get a short shift kit and a new shifter relocater from them, i already had a tail shaft and bellhousing adapter plate so i didnt end up getting the whole kit as much as i should of coz they are the ducks nutz.

Anyways, me and a mate dropped the box, put the new shifter and relocator on and WOW! what an incredible difference. So quiet, such nice short shifts too and no slop. Awesome. I also got one of their speedo correctors, so i had that wired in and away i went. All good.

pics:

how the knob sat after box was first installed

46853_1465722888674_4696679_n.jpg

How it sat AFTER the alpha omega shit went in

46535_1465723208682_925321_n.jpg

46626_1465723328685_705768_n.jpg

 

So a little amount of time went by and after starting to get comfy in the car and starting to throw it around a little bit i notice the diff was a little bit dangerous, sometimes you'd be hangin it out and all of a sudden it shoots off towards a gutter! The diff was pretty 2nd hand, so i hunted around for a diff for a week or so and found one on nengun for cheap, Nismo GT PRO 1.5 way lsd. So i bought that and bought new bearings and seals and redline diff oil and we pulled it apart and put it in.

Had a bit of a head f**k on our hands when we first pulled the diff out as the half shafts were different lengths and wouldnt go in the diff, so we took one of them down to my mates work and spun off about 30mm on the lathe... I don't recommend this, as it wasnt a real tight fit and going around corners slowly it felt like the whole wheel was moving side to side lol but it worked untill i could organise a new shaft that would fit. Just needed another stock nissan s14 short shaft.

 

pics

 

286415_2070435366108_4218447_o.jpg285974_2070432086026_2867118_o.jpg285896_2070431005999_6163228_o.jpg289262_2070429845970_6340702_o.jpg289789_2070428565938_284526_o.jpg194649_2070426885896_3525452_o.jpg289698_2070425565863_1705310_o.jpg

177171_3670606089376_1512963268_o.jpg

Edited by DRE20

Share this post


Link to post
Share on other sites

Next, I decided it looked a little gay with stock s15 alloys and orange front indicators, so i put some rims on it. Yep, all 20 inches haha and some clear indicators

66644_1518289162798_2260473_n (1).jpg66974_1518289082796_5322331_n.jpg73404_1518288242775_87545_n.jpg73445_1518288682786_7207824_n.jpg

 

next up was some rear suspension arms as the rims didn't sit right at first (also some led taillights)

413641_3689948972936_594195558_o.jpg

178311_3689973653553_864388492_o.jpg

Edited by DRE20

Share this post


Link to post
Share on other sites

So pretty much everything went well for about 8 months, i had a few dramas with tuning it, had it tuned 3 times and everytime there was dramas, the 2nd time in particular the guy butchered the tune, i was getting around 250ks to a tank and it was barely putting out 200kw atw, was running really rough and shit and it was pissin me off, lucky i never paid him for the tune, so i drove it to townsville and they had a go, and it made 213.1kw atw on 18pounds...

It went well for about a month, then one winter morning after work took it for a long drive and got stuck into it, it started popping and carrying on then came good, so i decided to do a 2nd gear drift, took the corner pretty sideways, clicked 3rd coming out and then a piston let go... FML

297048_2066571069503_1401573302_32166576_3248490_n.jpg293351_2066573469563_1401573302_32166582_1360936_n.jpg294189_2066577389661_1401573302_32166590_6057070_n.jpg

as you can see in the pics, nice little hole in the piston, wrecked the top of the cylinder and the head was looking pretty 2nd hand aswell...

Then i decided i wanted a tough SR, so after abit of researching i got onto SR NRG aka Donny, and had a bit of a yarn and we decided on a combination i was happy with that would help me reach 300kw. So i asked Donny to build me a new engine, this is when the fun began.

 

Donny also got me onto the boys at Eastcoast Customs, So after a few phonecalls, trucked my car to EastCoast so they could pull engine out and send it to donny so he could rebuild it.

 

They had it out within days of it being there and sent. After about 9-10 months of SR NRG having the motor things started happening.............

 

While i was waiting for my engine to be built, decided not to put the 2876r back on as it wouldnt reach my goal of 300kw, so i got a Precision 5858 Ballbearing for it (mainly went with precision as almost no one had put this exact turbo on a forged SR20 yet, well, not that i could find anyways) and a Brae Exhaust manifold, Tial 44mm MVR wastegate in purple, a new DCS Hi Torque Cushion Ceramic Clutch, and after the engine blowing up i decided to go a different way with the ecu so i had the Microtech pulled out and put a Link G4 plug and play ECU in it and a Link Knock light, also decided on some new injectors, so i got ID1000cc with a BPP fuel rail kit...

 

New Engine specs

 

90mm CP pistons and rings

Manley Rods with ARP rod bolts

Darton sleeves

ARP head studs

Mazworx head gasket

Tomei Solid Lifter conversion

New rocker arms

New Oil pump

New water pump

Tomei Solid PROcams 260/12mm in & exh.

Tomei Adjustable cam gears

BC springs

New valves

 

crank crack tested and linished and shot peened

Block acid dipped

Head ported and polished

all new gaskets and seals throughout

Balanced and blueprinted

(probly some things im forgetting but you get the idea)

Donny was kind enough to send me a few pics :D

322019_10150614798610429_671085428_11566901_559449317_o.jpg194709_10150614841490429_671085428_11566962_1975981688_o.jpg210890_10150614842710429_671085428_11566964_568493584_o.jpg328714_10150614989215429_671085428_11567268_76526949_o.jpg328868_10150614988615429_671085428_11567265_202961566_o.jpg330303_10150614610060429_671085428_11566061_1917617440_o.jpg340771_10150614958240429_1632505690_o.jpg341195_10150614759515429_671085428_11566777_103561047_o.jpg341330_10150614960550429_671085428_11567209_1933507665_o.jpg410929_10150614945440429_671085428_11567146_1244961122_o.jpg406517_10150629460015429_671085428_11610738_165386684_n.jpg402527_2803818300223_1401573302_32554033_2029217568_n.jpg421882_10150629345455429_671085428_11610576_1795483633_n.jpg408889_2803801539804_1401573302_32554028_729871834_n.jpg426970_357718004251767_340693932620841_1110619_1351461173_n.jpg

Edited by DRE20

Share this post


Link to post
Share on other sites

So the engine turns back up at EastCoast Customs (happiest day of my life to date!!) and the boys got onto it f**king PRONTO. Well done boys haha and rob sent me a few pics of things as they went along...

 

528408_420900734592654_1848666936_n.jpg528987_425669157449145_801833378_n.jpg548854_425669090782485_1590021721_n.jpg549809_425669117449149_830366302_n.jpg548013_425670000782394_49946590_n.jpg559389_425669964115731_2079669730_n.jpg544654_425670244115703_136141150_n.jpg545752_425670137449047_1126413897_n.jpg534060_432447823437945_783715913_n.jpg467232_3288205049589_2042131440_o.jpg374073_432448443437883_1787730608_n.jpg405047_425670537449007_877396518_n.jpg457121_3288398094415_635776604_o.jpg

 

Ok so after a few little dramas like someone sending out the wrong injector rail that put this build back by around 1 week, doesn't seem like such a big deal now but when it happened it was a major catastrophe, Rob finally got it on the dyno, it started tuning up pretty good then my peice of junk malpassi fuel reg wouldnt hold pressure properly or give correct readings, so that got binned and a Tomei Type L was thrown in, then one of my Bosch coil packs shit itself, so had to wait another day for another one of them.... But after all that, she started tuning up pretty well...

 

This video is the final powertune, it was tuned up twice in the first week it was going, the run in tune was around 240kw on 12 pounds

http://youtu.be/104FcqYdjsY

 

http://youtu.be/0czI41OuXAA

 

 

So after around 4000k's of having the car back.... Everything was going fine, it survived going down the drag strip a few times, doin some skids, just generally getting to know the car again, not overly trashing it but not babying it either, generally just keeping off the limiter as much as i could haha

 

one night me and a few mates were all out in our sils, and one of the boys says to do some launches coz i wasnt keen on sliding it as the tyres i had on had to get me home lol, so i did... Anyways, my mate decides to record it on his phone so i stall it up and launch it, then i come back and my mate tells me i'll have to do another one coz he didnt have it on video camera lol, so i stall it up again and do another launch, and i come back and this time he says sorry bro youll have to do it again coz i accidentally took a photo instead of recording it lol and you know what they say!! 3rd time lucky!!! haha on the 3rd one whilst changing into 2nd gear it smashed 2 rockers :( but we couldnt work it out untill the next day when i took the rocker cover off...

 

414225_3413502901957_869138961_o.jpg

 

 

 

so then i had to tow it over 1000k's home... f**king MISSIONNNNNNN!!!!

 

476449_3382447485591_626455528_o.jpg

 

So then i gets it home, pull it all apart, get new rockers, put them in, fire it back up and went out for a cruise, all was good. Back in business. Sure enough, the very next morning on the way to work, snapped 2 rockers AGAIN!!. by this time im ready to burn the f**king thing to the ground. Only this time it wrecked the exhaust cam and shattered the rockers much worse and i lost 2 shims inside somewhere so had to drop the sump again and pull cams out this time...

 

458170_3478849295576_1866107038_o.jpg461201_3478828815064_152792285_o.jpg475651_3478825854990_842660492_o.jpg476227_3413424820005_1122545577_o.jpg

 

so i bought a new cam, new test shim kit (waste of money didnt even end up using it) new rockers, oh and a new front lip. Faarrk yeah!

469804_3581836630195_723323085_o.jpg

 

So after this happened again i was f**king pissed off, as you could imagine, freshly rebuilt engine and its smashing rockers daily, so after talking to everybody we decide the limiter is set wrong, it was set to ignition cut, so a new limiter was made up and sent to me in an email, ready to be uploaded onto the ECU when we finally start it back up again.

 

Anyways, got all the bits of rocker out and found the 2 missing shims when i pulled the cams out they were stuck in where the timing chain goes, Got the new bits and a mate and I set all the timing up and fired it back up, and it wouldnt start.... So we pulled rocker cover off again and checked timing, also checked the Cam angle sensor, sure enough, it was 180 degrees out, so we rectified that, put it back together and viola! Back in business. biggrin.png

Edited by DRE20

Share this post


Link to post
Share on other sites

Very nice set up. Looking the same amount of power with a built engine.

 

If you don't mind can you pm me. I have some questions that you can answer for me. Cheers

Share this post


Link to post
Share on other sites

nice one bro, be sure to let me write the part of the story that i know about, with matt telling you to do launches..

 

i am an EXCELLENT story teller ;) hahahahahah

Share this post


Link to post
Share on other sites

nice one bro, be sure to let me write the part of the story that i know about, with matt telling you to do launches..

 

i am an EXCELLENT story teller ;) hahahahahah

 

hahaha yeah i will let you do the honers for that one. I will get stuck into trying to finish it off tonight, theres so much ive missed but it was late n i got tired...

Share this post


Link to post
Share on other sites

NIce mate. Looks like a killer setup. I can only imagine how you felt when that engine turned up!!

Share this post


Link to post
Share on other sites

what the hell is with people installing motor's with big turbos hanging off them takes 10mins

 

to pull it off and leaves so much more room once its in reinstall it so lazy

 

loving the slant on the thing to lol

Edited by 1400R

Share this post


Link to post
Share on other sites

so this happened... tru story bro.

 

336407_3670603849320_743354797_o.jpg

Share this post


Link to post
Share on other sites

says-cool-story-bro_actually-means-it.jpg

 

 

 

 

that actually looks like realistic fitment and I like it..........I like it alot :-) I know at least two people that require wheel and tire specs.......immediately please good sir.

Edited by datsun180

Share this post


Link to post
Share on other sites

hahaha well, their no where near how i want them to sit but they were just quickly put on and aligned, rears are 18x10s with 35 profile 265 wide tyres in a +18 offset, with about 4.5 degrees negative camber and as close too zero toe as we could get them...

fronts are 18x9's with a 45 profile tyre and 235 wide in a +30 offset...

 

pics of the rears with 0.5 degrees negative camber

 

411859_3670443725317_971315644_o.jpg

 

 

pics of how it currently sits

277998_3682406584381_1946263222_o.jpg

 

fronts look a little gay but i will get it there...

177171_3670606089376_1512963268_o.jpg

Share this post


Link to post
Share on other sites

So decided to put this heap of shit into a little test and tune and see how loud the stereo is in it.. i thought "oh yeah might be lucky to get 120db... ended up playing this song:

 

http://youtu.be/ogMNV33AhCY

 

and got 134.3db!! pretty stoked with that considering i have 1 12inch sub.

my result on the right..

391334_3682915917114_1951987684_n.jpg

Share this post


Link to post
Share on other sites

sooo theres an 1/8 mile drag racing thing on in my area this weekend, thought i'd go to it and try practice some launches coz last time i ran this thing on the strip i had 205 street tyres and my 60ft times were like 2.8 seconds :P

 

so i got 2 of these

255/50/16

et_street_radial_b.jpg

Share this post


Link to post
Share on other sites

not too sure just yet, still unsure of these volks, thinking bout selling them and getting something with a better offset so i can run an 18 inch 265-285 rear tyre so i can stop it from lighting the tyres up when it comes onto boost, once ive finally figured out what rims i want to get ill probably look at a usdm rear bar and luxury skirts then paint.. It needs paint quite badly..

Share this post


Link to post
Share on other sites

Paint is over rated. The less paint you have means less weight bro.

Share this post


Link to post
Share on other sites

paint makes the bitches moist bruv :D i'm all about the moistness haha

Share this post


Link to post
Share on other sites

paint makes the bitches moist bruv :D i'm all about the moistness haha

 

You'll be moist on the weeknd ;)

Share this post


Link to post
Share on other sites

paint makes the bitches moist bruv :D i'm all about the moistness haha

 

You'll be moist on the weeknd ;)

if i can get the little f**ker to launch, quite possibly!

Share this post


Link to post
Share on other sites

paint makes the bitches moist bruv :D i'm all about the moistness haha

 

You'll be moist on the weeknd ;)

if i can get the little f**ker to launch, quite possibly!

 

That can be twisted to sound soooooooo seedy :quagmire: :quagmire:

Share this post


Link to post
Share on other sites

cant wait to get out and try these bad boys out... Hope nothin breaks!

559260_3753689646413_17876319_n.jpg

Share this post


Link to post
Share on other sites

^^ That makes me happy in my pants.

 

haha wish i could run em on the volks, that would be epic fatness

Share this post


Link to post
Share on other sites

Hey bro, got more details regarding how your Rev limiter was and how it is now? Did you set the soft cut span to a bigger range or something?

Share this post


Link to post
Share on other sites

hmm, its hard for me to explain because im only new to links and the whole rev limit thing but as far as i can recall it was set to "IGN%cut" so we changed that to Fuel%cut and it had advanced mode on but before it had adaptive set to on and now its just changed to constant, The current new settings are the same as the old ones only things we changed are what i just mentioned

 

cut effect was constant,

the limit control range was 200rpm,

hard limit is set to 0rpm,

end cut is 100%,

start cut (TP 100%) is 60%,

start cut TP low is 0%TP,

the exit decay rate is 5%/20ms,

and the last value is Limit ignition trim -5.0degrees.

 

if you need any more info on it dude dont hesitate to ask, ive got all my settings saved on the computer so i can just open it and look peice of piss.

Are you running the mighty link in your new setup?

 

heres a screenshot anyways

Untitled.jpg

Edited by DRE20

Share this post


Link to post
Share on other sites

Ok so something thats been pissing me off about this f**king car is since the day i got it back, its always leaked radiator fluid, so yesterday im gettin my semi slicks put on and aligned as they need about 1ish degree of camber to fit in the gaurds as the rims i got for them are yet again a shithouse offset, and i notice radiator coolant dripping, so im like oh wtf! Anyways its just the bottom hose where it connects onto the engine its leaking from the clamp, ive already tightened the f**k out of it but its still leaks so im going to rip it off and put it on there again as im sick of smelling radiator fluid through my car and if its leaking tomorrow for scrutineering they might not pass me so f**k that im gunna fix it today. Pics up soon :)

Edited by DRE20

Share this post


Link to post
Share on other sites

I see a sneaky sr floating around in the background of a couple of them pictures :P. Good to see its running mate, think yourself lucky that your only breaking 1 or 2 rocker arms and not every rocker arm and bending most of the valves like i did... Try taking the hose off and giving the inside a clean and then putting it back on. Ive been away for work since yours was getting built so im finaly screwing my ve head on this week! Btw nice slicks thats the exact same size im running :)

Edited by danjor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×