Jump to content
Sign in to follow this  
55psi

Full lock changes wheel alignment. WHY!?

Recommended Posts

Hey guys,

 

Got a bit of a weird problem at the moment. Whenever i go full lock left or right, the left side coilover makes spring 'boiing' noises. And the other issue is when i go full lock to the left and drive straight, it tracks to the left, and vice versa when i go full lock to the right. But when I 'centre' the steering by correcting it a bit, it drives straight...

 

I've replaced my steering rack bushes with superpro stuff, so it cant be the rack. I dont get why the coilover is making the spring noises as if its not seating properly even though i tightened up all the collars, and made sure the spring is not floating when theres no load on it.

 

Anyone got any ideas? Only thing i can think of is the coilover is somehow fkd.?...

 

Cheers

Jas

Share this post


Link to post
Share on other sites

the coilover spring is catching on the collar. you need a plastic spacer between the 2 metal surfaces or a torrington (sp) bearing in there.

 

isc coilovers in a s-chassis?

Share this post


Link to post
Share on other sites

Yeah thats what i thought, spring catches on the collar when the coilover is loaded, but when its up in the air, doesnt happen. Theyre ebay spec coilies in an r31 with s13 front end.

 

Do you have an idea of why its changing the alignment everytime i go full lock though?

Share this post


Link to post
Share on other sites

Ahh ok thanks. I'll look into it. didn't know spring binding could cause it to fk up the alignment...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×